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1 Getting Started

1.1 Hardware Overview

CMAS connects to any SHM system supporting the OSDAM API. Winstalled on a host PC, CMAS can connect
to an SHM system directly or indirectly using an OSDAM unitiré2t connections are useful when communicating
with one device. An example of this is using CMAS to conned¢hvain AN110 DAQ node shown in Figure 1.1(a).
However, if there are several SHM systems in the region, t8®A&M, shown in Figure 1.1(b), is used to establish
a mesh network. In this configuration, CMAS connects to th®®8, which provides a list of all the available
SHM systems in the area along with a wireless access poimytofahe SHM systems in the network. The OSDAM
connects the host to multiple SHM systems (up to 16 in totaf).achieve this, a set of commands and responses
are sent between the host and OSDAM and relayed through & setnonands sent between the OSDAM and SHM
system as shown in Figure 1.2.

Wether CMAS is used to connect with a SHM system either diyremt indirectly, the process of initiating data
logging, download and realtime modes remains the same.efdrer with the exception of connecting to a specific
target device, the remainder of this document will assume\Gh4 directly connected to an SHM system.

(b)

Figure 1.1: Photo of (a) AN110 DAQ node (SHM System) conreeéteLPR sensors and (b) the Onboard SHM
Datastream Aggregator Module (OSDAM)

1.2 Mesh Network
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Figure 1.2: Block diagram illustrating command / resporsetsveen the host and SHM system when (a) connected
directly and (b) connected indirectly through an OSDAM.
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2 Installation

This section serves as a guide to ensure all the DVD conteatavailable, all necessary run-time files are installed
and the CMAS program runs properly.
2.1 Confirm DVD Contents

Shipped with CMAS is a DVD containing the program file and epdrdatasets. Before continuing ensure the
following are available:

4 Step 2.1 Confirm the contents of the DVD:

o CMAS.exe
¢ MCRInstaller.exe

2.2 Confirm Hardware Requirements

CMAS requires a minimum amount of system requirements talinsnd run properly.

4 Step 2.2 Confirm the workstation / computer meets the following minimrequirements:

e The processor meets or exceeds: Dual-core 2.0GHz
e The operating system: Windows XP, Vista, 7 or 8 (32 or 64-giitian)
e The amount of available memory: 4GB of RAM

If all of the system requirements are satisfied, then coettolSection 2.2.1.

2.2.1 Install MATLAB Compiler Runtime (MCR)

4 Step 2.3 Install the MCR library version 7.16 by running the file MCRtaller.exe located on the DVD.
(Skip this step if MCR version 7.16 is already installed).

2.2.2 \Verify Installation

To verify that CMAS was installed successfully:

4 Step 2.4 Locate the file named CMAS.exe on the DVD.
v/ Step2.5  Run CMAS.exe.

4 Step 2.6 Confirm the main window appears as shown in Figure 2.1.

If the program is not running properly then refer to the FAQtem. Otherwise, close the main window:
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Figure 2.1: Main GUI window of CMAS.

4 Step 2.7 Close the program by clicking the X button in the upper riganth corner of the main window.
This can also be done by clicking Fite Close... from the main-menu bar or pressing the key

combination[Cirl] + [Q] -

" Note: CMAS can also be copied local hard drive and run using the sstepes as presented in this
section.
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3 Main Layout

All program functionality is accessible by either using thenubar or the toolbar. A status panel provides a brief
description about the current database, configuratioimgsetand the status of any processing. A debug panel identifie
current actions and processing activities taking place.

JIN CMAS v1.09 Beta [l & |
File Commands Tools Help o
sS¢c/opHE A|[OO [2)
(] Y- <
Target Device Type: |Auto Detect = Available SHM Nodes: \N/A
C Status: Di q Current operating mode: - o
» A
Device Type: - YT ~
Communication Port: -
Model: - e e
Manufacturer: -
Firmware Version: -
Serial Number: -
— A Y,
([ N\
{A
()
) (6]
]
= .

Figure 3.1: Layout of the main window with numerically idiied components.

3.1 Components

All the components of the main window identified numericatiyrigure 3.1, are listed in Table 3.1 with a description
corresponding to each.

Table 3.1: Description of components in the main window

ID Description

ID1 Menubar bar containing all program functionality. A deption of each menu item and sub-menu item
is provided in Section 3.2.

ID2 Toolbar were each button corresponds to an item in theudan A description of each toolbar button is
provided in Section 3.2.

ID3 Connection panel displaying information about the ctad device.

ID4 Target-device panel displaying the information for tamget SHM system and current operating mode.

ID5 Table showing the properties and corresponding valoethé targeted SHM system.

ID6 Debug panel used to display command and response inframma

3.2 Menubar / Toolbar

A summary of each toolbar button, menubar item and sub-igepnavided in Table 3.2 along with a description for
each action.
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Table 3.2: List of toolbar button / menubar items with a diggion.

Icon Menu ltem

Sub Menu ltem

Action / Description

File > Connect Connects to the first target type defined in the dpaoel (ID3)
Disconnect Disconnects from the target device.

Close Closes the main program window.

Commandsr> Get Monitor Info...  Refreshes the property table (ID5).

List Monitors... Refreshes the list of available SHM nodethie end-device panel (ID4).
SetMap ID... Configures the Map IDs for one or all of the avddsSHM nodes.
Get/Set Params... Opens the Get/Set parameters dialog box.

@ Realtime... Initiates real-time logging for the selectéthvBnode in (ID3).

Start Logging... Initiates remote logging for the selec®tM node in (ID3).

Stop Logging... Returns the selected SHM node in (ID3) te idbde.
Download... Downloads available data from the selected Sidtie in (ID3).
Tools >  Settings... Shows the “Settings” dialog box.

Debug Port... Shows the “Debug Communication Port” dialog. b
Help > Documentation... Shows this document.
About... Shows the “About CMAS” dialog box.

3.3 Panels

This section describes in more detail the connection pdb&l)( target device panel (ID4), property panel (ID5) and

debug panel (ID6).

3.3.1 Connection Panel

The connection panel is used to select the type of connedévice and display the connection status. A description

of each of the fields is provided in Table 3.3.

Table 3.3: Connection panel fields and corresponding deamms.

Field Editable? Description
Taraet Device Sets the connection device as 'SHM System Node’, 'OSDAMAurtb
T ge Yes Detect'. If auto detect is selected, CMAS will begin by sd&amg for an

yp OSDAM device and then continues by searching for a SHM Systede.
Connection No Returns the connection status as either 'Disconnectedhn@cting’ or
Status 'Connected’.
Device Type No Shows the type of connection device CMAS is attempting toneghto or is

connected with. If the connection status is '‘Disconnected’device is shown.
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Field Editable?

Description

Communication

Shows the communication port of device CMAS is attemptingaonect to or

Port No is connected with. If the connection status is 'Disconné’cteo

communication port is shown.

If connected, then the model of the connected device is sh@therwise, no
Model No . .

model information is shown.

If connected, then the manufacturer of the connected dévs®gown.
Manufacturer No i ) L

Otherwise, no manufacturer information is shown.
Firmware No If connected, then the firmware version of the connectedcgagishown.
\Version Otherwise, no manufacturer information is shown.

Serial Number No

If connected, then the serial number of the connected devE®own.
Otherwise, no manufacturer information is shown.

3.3.2 Target Device Panel

The target device panel is used to select the type of corumedtvice and display the connection status. A description

of each of the fields is provided in Table 3.4.

Table 3.4: Target device panel fields and correspondingipéists.

Field Editable?

Description

Target Device

If connected directly to an SHM system node, then the Avl&HM node is
set to the connected SHM system node by default. Otherisennected to

Tvoe Yes an OSDAM, the targeted SHM system node can be selected frighad |
yp available nodes in the network. Each SHM system node iglliséing the
following format: “<manufacturer>: <model> : <serial nuprb”
Displays the current operating mode of the targeted SHMegysValid modes
Current No are idle ('IDLE’), download ('DNLD"), logging (LGNG’), logging and data

Operating Mode

download ('LGDL) and realtime 'RLTM'. If there is no targ&@HM system
currently active, then the current operating mode is blank.

3.3.3 Property Panel

The property panel displays the properties and correspgmnailues for the targeted SHM system. Common properties

include, but are not limited to those in Table 3.5.

Table 3.5: Property panel fields and corresponding degmnipt

Field Description

Datetime Date and time of the current Iogging_ session in_ UTC formaho_lﬁ_atg is available to
download or the SHM system node is not logging data, therfiglsis empty.

Firmware Latest firmware version.

Free Memory Amount of free memory in kilobytes.

Manufacturer Name of the hardware manufacturer.

10
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Field Description
MapID Assigned MapID. This number can range from 1-16.
Model Name of the hardware model.
Num Sensor Groups Total number of available sensing groups.

Description of thé™ sensing group identified by name, description, engineeniitg,

Sensor Group # number of sensors in the group , sample period, and the numhbecorded samples.

Serial Number Serial number corresponding to the hardwaite u

3.3.4 Debug Panel

The debug panel displays command and response informatida wsing CMAS. The panel consists of a set of
toolbar buttons to the right and a listbox occupying the riewher of the panel. A description of each of the toolbar
buttons is provided in Table 3.6.

Table 3.6: Debug panel fields and corresponding descrition

Description

Expands the main window to show the debug panel.

Collapses the main window to hide the debug panel.

Clears the debug information from the listbox.

Copies the debug information from the listbox to the systépboard.

BE@m©] s

Saves the debug information from the listbox to a file.

11
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4 Connect/ Disconnect SHM System Node

CMAS connects to any SHM system supporting the OSDAM API. Winstalled on a host PC, CMAS can connect
to an SHM systendirectly orindirectly using an OSDAM unit. Direct connections are wse@fhen communicating
with one device. However, if there are several SHM systenthénregion, the OSDAM can be used to establish a
mesh network. The procedure for each of these connecti@s tgre provided in Sections 4.1 and 4.2, accordingly.

4.1 Connectionto SHM System Node (Direct)

The process for connecting to a SHM system node directly fkned in Figure 4.1. The process is initiated from
CMAS by setting the target device type to 'SHM System Nodel alicking the connect button (See Section 4.1.1).
First, CMAS opens all available comports one at a time logKor a SHM system and waits for a response. If no
responses are received on any of the available comports, £Aninates any open comports. Otherwise, CMAS
keeps the current comport open and checks if the unit hasicaMalpID. If not, CMAS will assign a MaplD. If a
MaplID cannot be assigned, CMAS remains connected but theeotion process does not continue until the MapID is
set manually (see Section 4.1.1). Once a MaplD is assigndé3Csends a monitor info request to the SHM system.
If the SHM system does not send back a response to the mamfitwmiation request, then CMAS remains connected
but the connection process does not continue until the miomiformation is retrieved manually (see Section 4.1.3).
Once the SHM system sends back the monitor information sstuéy, CMAS will display the information in the
property panel. At this stage CMAS is successfully conreeitethe SHM system enabling the use of the logging,
download and real-time monitoring commands. Finally, teerican terminate the connection with the SHM system
at any time (see Section 4.1.4).

L Legend
Initiate
Connection 1 Command can be executed from CMAS toolbar or menubar.
Internal process between CMAS and the SHM system node.

¢ B Connection incomplete. Follow recommendation to complete connection
B Successfully connected.

Open
P <—— Automatic path (executed from original command)
Comport . .
<a- - - Manual path (executed with command to resume connection process)
Send
Yes »<_MaplID(s) Set? Yes Monitor Info
A
Request

iNo

- 1 Set MapID(s)

Monitor Info
Received?

Unscanned
Ports?

>

Terminate

Connection

l A4
Connected
- o - Successfully!

Check comport connections Reset MapID Resend monitor info Proceed to data
and reconnect request logging, download and
realtime monitoring.

Figure 4.1: Flowchart of the direct connection process.

12
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4.1.1 Initiate Connection

The following steps are used to initiate a direct conneatith a SHM system node:

v’ Step4.1

v’ Step4.2

v Step 4.3

Establish a physical connection between the SHM system andéost computer. If the con-
nection is RS232, plug the SHM system node into an availal§232 port (This can also be
achieved by using an appropriate USB-t0-RS232 adaptetheltonnection is wireless, make
sure the wireless SHM system is in close proximity to the leostputer and the host computer
has the wireless ZigBee USB adapter plugged in with the agjate drivers installed.

Select 'SHM System Node’ from the target device type listtmpated in the connection panel.

Click File > Connect... from the main menubar. This can also be achieyetidking the
button from the toolbar or by the keyboard combinatjaad] + .

If a SHM system is found on any of the available comports, CM#i automatically begin the process to set the
MapID and send a monitor info request. In the event eithehe$¢ processes fails, CMAS will remain connected to
the SHM system and the MapID or monitor info request will neetle sent manually. An alternative approach is to
disconnect from the SHM system and initiate another conorect

4.1.2 SetMaplD

The MapID is important as it distinguishes a SHM system nadmfother nodes in the network. In the case that
the SHM system is connected directly to the host and is ndtgiaa network, it still needs to have a valid MapID
assigned. The MaplID can be assigned by the following:

v’ Step 4.4

v/ Step 4.5

From the main menubar click CommandsSet MaplID... > Unassigned/duplicate. A 'SHM
System Parameters’ dialog box will appear, as shown in Eigu2, displaying the status of the
set MapID parameter and the time remaining to receive a vatidin.

If no response is received and the 'SHM System Parametaiiglbox is still displayed, the
MaplID can be resent by clicking on the 'Retry’ button. Additally, the process can be termi-
nated completely by clicking on the "Cancel’ button.

If the MapID was set successfully, CMAS will automaticallgdin the process to send a monitor info request. In the
event the MaplD was not set, repeat the previous steps edtimthis section.

SHM Systern Parameters El = @

Status: Setting / getting SHM System parameters (1 of 1)...
Progress: 20 seconds left

0%

| Retry | | Cancel |

Figure 4.2: 'SHM System Parameters’ dialog box.

13



ANALATOM

Structural Health Monitoring Solutions

Corrosion Monitoring & Assessment
Software (CMAS) User’'s Manual
Version 1.23 Beta

4.1.3 Send Monitor Info Request

The monitor info command is used to update the property paitielthe properties and corresponding values for the
targeted SHM system. A monitor info request can be sent by:

v’ Step 4.6

v’ Step4.7

Click Commands> Get Monitor Info... from the main menubar. This can also beiaed
by clicking the button from the toolbar or by the keyboard combinatifm] + A
'Retrieving Monitor Info’ dialog box will appear, as showm Figure 4.3, displaying the status of
the monitor info request and the time remaining to receiveréivation.

If no response is received and the 'SHM System Parametealglbox is still displayed, the
monitor info request can be resent by clicking on the 'Relytton. Additionally, the process
can be terminated completely by clicking on the 'Canceltdvuit

Once the monitor info response is successfully received¢timnection to the SHM system is complete enabling the
use of the logging, download and real-time monitoring comdsa A screen capture of CMAS successfully connected
to a SHM system node is shown in Figure 4.4. In the event theitoroinfo response is not received, repeat the

previous steps outlined in this section.

u Retrieving Menitor Info

Status: Retrieving SHM system information. ..

Progress: 20 seconds left

Cancel

|

[ Retry

)

Figure 4.3: 'Retrieving Monitor Info’ dialog box.

B cmAS v1.09 Beta =] =
File Commands Tocls Help
F & el @bl L OO0
Target Device Type: |SHM System Node Target SHM System Node: | Analatom:AM110:3/M 0001 -
CanTicaton Satne: ol Current operating mode: [DLE  (ready)
Device Type: ‘SHM System Node Property Value
Communication Port- COM2 Dlatetlme 2013-04-1018:06:282 -
Firmware FW1.00 | W
Model: AN110 Free Memaory 32564 (samples)
: Manufacturer Analatom =l
Manufacturer: Analatom MaplD 1
Firmware Version: FW1.00 WModel ANT10
iNum Sensor groups 3
Serial Number: S/N 0001 [Sensor group 1 MName=LPR: Desc=Linear Polarization Resistance; | -
|J | T b

Figure 4.4: Screenshot of CMAS after successfully conngdth an SHM system node.
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4.1.4 Terminate Connection

See Section 4.3 on page 17.

4.2 Connection Using OSDAM (Indirect)

The process for connecting to a SHM system node indirecttyuiifh an OSDAM is outlined in Figure 4.5. First, the
process is initiated from CMAS by setting the target devigeetto 'OSDAM’ and clicking the connect button (See
Section 4.2.1). CMAS opens all available comports one aha tooking for an OSDAM and waits for a response. If
no responses are received on any of the available compdtaSQerminates any open comports. Otherwise, CMAS
keeps the current comport open and sends a request to ligtta# available monitors. In the event that no monitors
are listed after the list monitors request has been sent, Ek&mnains connected but the connection process does not
continue until the request to list monitors is manually gsee Section 4.2.2) Otherwise, if the number of monitors
received is one or more, then CMAS will automatically begjia process to set the MapIDs for each available SHM
system listed. If a MapID cannot be assigned, CMAS remainsected but the connection process does not continue
until the MapID is set manually (see Section 4.2.3). Once plMas assigned, CMAS sends a monitor info request to
the SHM system. If the SHM system does not send back a respmtise monitor information request, then CMAS
remains connected but the connection process does nohaenintil the monitor information is retrieved manually
(see Section 4.2.4). Once the SHM system sends back theanaridgrmation successfully, CMAS will display the
information in the property panel. At this stage CMAS is sxfully connected to the SHM system enabling the use
of the logging, download and real-time monitoring commarkdisally, the user can terminate the connection with the
SHM system at any time (see Section 4.2.5).

L Legend
Initiate
Clomceiien 1 Command can be executed from CMAS toolbar or menubar.
Internal process between CMAS and the SHM system node.
¢ B Connection incomplete. Follow recommendation to complete the connection process
Open B Successfully connected.
P <—— Automatic path (executed from original command)
Comport . .
<a- - - Manual path (executed with command to resume connection process)

Send Send
List Monitors —»e—#<_ MapID(s) Set? > Monitor Info
Request Request

iNo

- 1 Set MapID(s)

Monitor Info
Received?

Unscanned
Ports?

/ ?
Terminate MapID(s) Set?

Connection

|
|
|
l l
: Connected
- - o - Successfully!

Check comport connections Resend list monitors Reset MapID Resend monitor info Proceed to data
and reconnect request request logging, download and
realtime monitoring.

Figure 4.5: Flowchart of the direct connection process.
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4.2.1 Initiate Connection

The following steps are used to initiate a direct conneatith a SHM system node:

v Step 4.8 Establish a physical connection between the SHM system andéhost computer. If the con-
nection is RS232, plug the SHM system node into an availal§23R port (This can also be
achieved by using an appropriate USB-t0-RS232 adaptetheltonnection is wireless, make
sure the wireless SHM system is in close proximity to the leostputer and the host computer
has the wireless ZigBee USB adapter plugged in with the gpjat drivers installed.

4 Step 4.9  Select 'OSDAM’ from the target device type listbox locatedhe connection panel.

4 Step 4.10 Click File > Connect... from the main menubar. This can also be achieyetidking the
button from the toolbar or by the keyboard combinat + .

If a SHM system is found on any of the available comports, CMWSautomatically begin the process to list all of the
available SHM system nodes, set the MapID for each availaHlel system node and send a monitor info request to
the targeted SHM system. In the event any of these procesite SIMAS will remain connected to the SHM system
and the list monitor request, MapID or monitor info requeskmeed to be sent manually. An alternative approach is
to disconnect from the SHM system and initiate another cotim

4.2.2 Send List Monitors Request

The list monitors request is used to update the list of abbEI&HM system nodes in the target device panel. A list
monitor request can be sent by:

4 Step4.11 Click Commands> List Monitors... from the main menubar. This can also be ek by
clicking the keyboard combinatio + . A 'List Monitors’ dialog box will appear, as
shown in Figure 4.6, displaying the status of the number dfiStstem nodes founds and the
amount of time remaining to receive responses.

4 Step 4.12 If all of the SHM systems nodes are found, click the 'Cancatttn to close the 'List Monitors’
dialog box.

4 Step 4.13 If none of the SHM system nodes have been found and the 'Listitds’ dialog box is still
displayed, the request can be resent by clicking the 'Réttton.

If the number of monitors listed is one or more, then CMAS wailtomatically begin the process to set the MapID and
send a monitor info request. In the event that no monitorfigtesl after the list monitors request has been sent, repeat
the previous step.

Listing Monitors EI = @
Status: Listing SHM system nodes... (2 found) s
Progress: 54 seconds left S
| Retry | | Cancel |

Figure 4.6: 'List Monitors’ dialog box.
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4.2.3 SetMaplD

See Section 4.1.2 on page 13.

4.2.4 Send Monitor Info Request

See Section 4.1.2 on page 13.

4.2.5 Terminate Connection

See Section 4.3.

4.3 Disconnect

The following steps are used to terminate a connection wiiM system node when connected either directly or
indirectly through an OSDAM.

v Step 4.14  Click File > Disconnect... from the main menubar. This can also be aediby clicking th
button from the toolbar or by the keyboard combinat + .

Once the connection has terminated the connection, taegetedand property panels become blank.
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5 Remote Data Logging and Download

CMAS can manage remote data logging and data download foSkiy system supporting the OSDAM API. The
procedures to manage remote data logging and data downleddeasame whether CMAS is connected directly or
indirectly to a SHM system node. Sections 5.1— 5.3 deschib@tocedures to initiate remote data logging, terminate
remote data logging and download data.

5.1 Initiate Remote Data Logging

Initiating remote data logging configures the SHM systemetodecord and internally store measurements from user
specified sensor groups were the sample period for eachrsgrag is user defined. Remote data logging can be
initiated from CMAS by following these steps:

4 Step 5.1 Click Commands> Start Logging... from the main menubar. This can also beexeli by

clicking the button from the toolbar. A 'Data Logging Options’ dialog besl appear, as
shown in Figure 5.1, displaying a table of available sensoupgs to log.

4 Step 5.2 Select the desired sensor groups to log by clicking the cheskcorresponding to each row in
the select column.

4 Step 5.3 Set the sample period to log each sensor group by typing im@batucorresponding to each row
in the 'Sample Period’ column.

4 Step 5.4  Click the 'Remote Logging (Internal)’ radio box.

4 Step 5.5 Click the 'OK’ button to initiate remote logging. The ’Inélizing Monitor Logging’ dialog box
will appear, as shown in Figure 5.2, displaying the staturitéting the remote data logging and
the amount of time remaining to receive a confirmation.

4 Step 5.6 If no response is received and the 'Initializing Monitor lgigg’ dialog box is still displayed, the
remote data logging request can be resent by clicking onRle¢ry’ button. Additionally, the
process can be terminated completely by clicking on the éghiutton.

Data Logging Options EI =1 IEI
Select row and set sample period for each of the sensor data groups to log:
Select | Sample Period [min] Description # Sensors Data Type Units
1 ] 1 Linear Polarization Resistance & Short positive float (SPLOAT)  ohms
2 v 1 PwrSrc 1 Half (precision) float volts
3 v 1 InfTemp 1 Half {precision) float deg C

— Logging Options

@ Remote Logging (Internal) Realtime Logging (Streaming)

| oK | | Cancel |

Figure 5.1: 'Data Logging Options’ dialog box for remote dirng.
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Initializing Monitor Logging El = @
Status: Initializing SHM system remote data logging... v

Progress: 20 seconds left *.?

| Retry | | Cancel |

Figure 5.2: 'Initializing Monitor Logging’ dialog box.

If the data logging is successfully initiated, then the 'f@mt operating mode’ field in the target device panel will
update from 'IDLE’ to 'LGNG'. In the event the remote data igg does not start, repeat the previous steps outlined
in this section.

" Note: Note: Atleast one sensor group must be selected, otherngs®K’ button in the 'Data Logging
Options’ dialog box is disabled.

5.2 Terminate Remote Data Logging

Terminating remote data logging informs the SHM system rtodstop recording data. However, any data previously
recorded and stored remains in memory. Follow these stepsitinate remote data logging:

v Step 5.7 Click Commands> Stop Logging... from the main menubar. This can also be aetidy

clicking the button from the toolbar. A dialog box should display similarFigure 5.3 to
confirm whether data logging should stop.

4 Step 5.8 Click 'Yes’ to stop data logging. A 'Stop Monitor Logging’ diog box will appear, as shown in
Figure 5.4, displaying the status of stopping the SHM systampte data logging and the amount
of time remaining to receive a confirmation.

4 Step 5.9 If no response is received and the Stop data logging confoniatialog box is still displayed, a
request to terminate data logging can be resent by clickmthe 'Retry’ button. Additionally,
the process can be terminated completely by clicking on@aamtel’ button.

Stop data logging confirmation, = | =]
@ Are you sure you want to stop logging data?
| Yes | | Mo |

Figure 5.3: 'Data Logging Options’ dialog box for remote ¢iing.
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Stopping Menitor Logging EI =] @
Status: Stopping SHM system remote data logging... eve

Progress: 20 seconds left

| Retry | | Cancel |

Figure 5.4: ’Initializing Monitor Logging’ dialog box.

If the data logging is successfully terminated, then therf€ut operating mode’ field in the target device panel will
update from LGNG to 'IDLE’. In the event the remote data laggdoes not stop, repeat the previous steps outlined
in this section.

2" Note: Sometime the SHM system receives the command to terminateteedata logging but CMAS
does not receive a confirmation. If this is the case, it may dmeccary to update CMAS by
sending a monitor info request (see Section 4.1.3).

5.3 Download Data

Data can be downloaded from the SHM system node when thewsystEperating in either 'IDLE’ or 'LGNG’ modes
and there is data available in memory to download. Its ingrdrto note that remote data logging does not have to
stop for data to be downloaded. To download data from the SiHvem:

4 Step 5.10 Click Commands> Download... from the main menubar. This can also be achibyedicking
the button from the toolbar. A dialog box should display whicdizates CMAS is sending
the SHM system a monitor info request similar to Figure 4.3age 14. If the request is sent
successfully, the 'Download Data’ dialog box should autbozdly appear, as shown in Figure 5.5
on the next page.

4 Step 5.11 Allow the data to download. The progress bar should incraagkall of the data is collected.

4 Step 5.12 Click "Yes' to stop data logging. A 'Stop Monitor Logging’ diog box will appear, as shown in
Figure 5.4, displaying the status of stopping the SHM systmote data logging and the amount
of time remaining to receive a confirmation.

4 Step 5.13 Wait for all of the data to download. Once the data is finishedroading another dialog box,
similar to that in Figure 5.6, will popup to save the data amlttal drive.

4 Step 5.14 Locate a directory to save the data, give the flename an pppte name, select the type of data
to save the file as, and then click the 'Save’ button.

There are multiple file types to save data as: *.chms, *.cglg**.xIsx and *.txt. The former is an application specific
format that can only be used by CMAS. The *.csv and *.txt fotsrean be opened using a text editor. Finally, the *.xlIs
and *.xIsx formats can be opened using Microsoft Excel (aieajent spreadsheet application program). In the event
the download does not initialize or the progress stops farentitan 30 seconds the connection may have timed-out.
Click the 'Cancel’ button and repeat the steps in this sactio
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n Download Data EIE@

Status: Downloading data from SHM system. ..
Progress: Data collected: 56 of 84 bytes

I

’ Retry ] ’ Cancel ]

Figure 5.5: ’Initializing Monitor Logging’ dialog box.

A\ Saveas @
Savein: Irtemal-TOW Test L] - I‘j‘ '
k= MName = Date modified Type
e B ; :
Hecerd)ljllaces . data 8/2/2013 10:49 AM File folder
Desktop
=gl
Libraries
Computer
-y,
a
Netwaork
| 10 k
File pame: Jm L] I—Iﬁave
Save as type: {Comma Seperated Varable {C5V) File (" cav) LJ Cancel

Figure 5.6: Downloaded data file types.
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6 Real-time Data Streaming

Similar to remote data logging, CMAS can also manage rea-tiata streaming for any SHM system supporting the
OSDAM API. The procedures to manage real-time data stregmithe same whether CMAS is connected directly

or indirectly to a SHM system node. Sections 6.1— 6.3 deschib procedures to initiate and terminate real-time data
streaming and how to use the data plots to display real-tite d

6.1 Initiate Real-time Data Logging

Real-time data logging is similar to remote data loggingegt¢he data is not recorded and stored locally on the SHM
system node. Rather, the data is streamed to the host at tmembéhe data is connected. This allows the data to
be viewed in real-time. Similar to remote data logging, Htéak data logging initially configures the SHM system
node to measure specified sensor groups were the sampld fmsrgach sensor group is user defined. Real-time data
logging can be initiated from CMAS by following these steps:

v Step 6.1 Click Commands>Realtime... from the main menubar. This can also be achigyeticking the

@ button from the toolbar. A 'Data Logging Options’ dialog bail appear, as shown before
in Figure 5.1 on page 18, displaying a table of available@egoups to log. The only difference
is the realtime logging option is selected.

v Step 6.2  Select the desired sensor groups to log by clicking the chegkcorresponding to each row in
the select column.

4 Step 6.3 Set the sample period to log each sensor group by typing im@batucorresponding to each row
in the 'Sample Period’ column.

4 Step 6.4  Click the 'Realtime Logging (Streaming)’ radio box.

4 Step 6.5 Click the 'OK’ button to initiate real-time logging. The 'ltializing Monitor Logging’ dialog box
will appear, as shown in Figure 6.1, displaying the statusitifiting the real-time data logging
and the amount of time remaining to receive a confirmation.

4 Step 6.6 If no response is received and the ’'Initializing Monitor lgigg’ dialog box is still displayed, the
real-time data logging request can be resent by clickindheriRetry’ button. Additionally, the
process can be terminated completely by clicking on the ¢8Bibutton.

If the real-time data logging is successfully initiateds turrent operating mode’ field in the target device pandl wi
update from 'IDLE’ to 'RLTM’ and a blank plot window will shovas seen in Figure 6.2. Refer to Section 6.3 on
how to display the real-time data in the plot window. In themthe real-time data logging does not start, repeat the
previous steps outlined in this section.

2" Note: Note: Atleast one sensor group must be selected, otherngs®K’ button in the 'Data Logging
Options’ dialog box is disabled.
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n Initializing Realtime Logging El' = '@
Status: Initializing SHM system realtime data logging... e
Progress: 20 seconds left E .o.

l Retry ]’ Cancel ]

Figure 6.1: ’Initiating Realtime Logging’ dialog box.

n Realtime Data Acquisition EI'E'@

File Options Help L

=

Mo Data Selected to Plot

Plot Mumber Sensor Description Sensor Group | Sensor Channel | Units | Period (sec) | idxDataSet
1 |Mone » Linear Polarization Resistance LFR Ch1 ohms 60 1 =«
2 |Mone » Linear Polarization Resistance LPR Ch2 ohms 60 1
3 |Mone » Linear Polarization Resistance LPR Ch3 ohms 60 1|2
4 |Mone » Linear Polarization Resistance LPR Ch4 ohms 60 113
5 |Mone » Linear Polarization Resistance LPR Chs ohms 60 10
6 |Mone » Linear Polarization Resistance LPR Ch& ohms 60 1
7 |Mone » Linear Polarization Resistance LPR Ch7 ohms 60 1) P
= g e — o T ' ST 3

Figure 6.2: 'Realtime Data Acquisition’ plot window.
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6.2 Terminate Real-time Data Logging

Terminating real-time data logging informs the SHM systemdato stop measuring and streaming data to the host.
Follow these steps to terminate the real-time data loggiagam

4 Step 6.7 Click File > Close... from the plot menubar. This can also be achievetbising the plot window
by clicking the close window button located on the titlebhany measurements were received a

dialog box, similar to that in Figure 5.6 on page 21, will ppgia save the data on the local drive.

v Step 6.8 Locate a directory to save the data, give the filename an pgpte name, select the type of data
to save the file as, and then click the 'Save’ button. Once #ia © saved, another dialog box

will show.

4 Step 6.9 A ’'Stop Monitor Realtime’ dialog box will appear, as shownHigure 5.4, displaying the status
of stopping the SHM system real-time data logging and thelarhof time remaining to receive

a confirmation.

4 Step 6.10 If no response is received and the 'Stop Monitor Realtimelatj box is still displayed, the ter-
minate remote data logging request can be resent by clickirtbe 'Retry’ button. Additionally,
the process can be terminated completely by clicking on@aamtel’ button.

If the real-time data logging is successfully terminatéant the 'Current operating mode'’ field in the target device
panel will update from LGNG to 'IDLE’. In the event the remalata logging does not stop, send a monitor info
request to the SHM system by following the steps in Secti@rB4on page 14. If the 'Current operating mode’ in the
target device panel still reads 'RLTM’, then follow the stap Section 5.2 on page 19.

Stopping Monitor Realtime El = @
Status: Stopping SHM system realtime mode_. e®s
Progress: 20 seconds left e
| Retry | | Cancel |

Figure 6.3: 'Stopping Realtime Logging’ dialog box.

6.3 Displaying Realtime Data
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